Python SDK

The Deep Security Python SDK consists of a package containing the module that you can use to interact with the API. If you would rather use the API directly via tools such as Postman and curl, you do not need an SDK.

For guidance on using the SDK, see First Steps Toward Deep Security Automation.

Get set up to use the Python SDK

Prerequisites

  • Python version 3.4 or higher
  • pip package manager

Download and install

    1. Download the Python SDK.
    2. Extract the Python SDK ZIP file.
    3. Open a Command Line or Terminal and change the current directory to the directory of the extracted contents.
    4. Enter the following command to install the module and dependencies:
      Windows

      python pip install .

      Linux/Mac

      sudo pip install .
If the Deep Security Manager in your development environment uses the default self-signed certificate for establishing secure HTTP connections and you do not import the certificate, you cannot connect to the server. You can disable the requirement for an SSL certificate by adding the following line to your code:
deepsecurity.Configuration.verify_ssl = False.
You should only disable SSL verification in development environments. For production environments make sure that SSL verification is on.